Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "File manager for the Xfce Desktop Environment" |
| 2 | SECTION = "x11" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | DEPENDS = "exo glib-2.0 gtk+ gdk-pixbuf libxfce4util libxfce4ui xfconf libsm dbus-glib startup-notification libnotify xfce4-panel udev" |
| 6 | |
| 7 | inherit xfce distro_features_check |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:3]}/Thunar-${PV}.tar.bz2" |
| 12 | SRC_URI[md5sum] = "8fea2af69c3acbb273fd1a177d3d8e47" |
| 13 | SRC_URI[sha256sum] = "e81291a8519f495e0a059ff1f2d29608bc6d37c0be83b1f38f3c9aa25f8d252d" |
| 14 | |
| 15 | S = "${WORKDIR}/Thunar-${PV}/" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[pcre] = "--enable-pcre,--disable-pcre,libpcre" |
| 19 | |
| 20 | FILES_${PN} += " \ |
| 21 | ${libdir}/thunarx-2/* \ |
| 22 | ${libdir}/xfce4/panel/plugins/* \ |
| 23 | ${libdir}/Thunar/[Tt]hunar* \ |
| 24 | ${datadir}/appdata \ |
| 25 | ${datadir}/dbus-1 \ |
| 26 | ${datadir}/polkit-1 \ |
| 27 | ${datadir}/Thunar \ |
| 28 | ${datadir}/xfce4/panel/plugins/* \ |
| 29 | " |
| 30 | |
| 31 | FILES_${PN}-dbg += "${libdir}/thunarx-2/.debug/ \ |
| 32 | ${libdir}/xfce4/panel/plugins/.debug/ \ |
| 33 | ${libdir}/Thunar/.debug/" |
| 34 | |
| 35 | RRECOMMENDS_${PN} = "gvfs gvfsd-trash" |