Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION="Thumbnail service implementing the thumbnail management D-Bus specification" |
| 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | DEPENDS = "dbus-glib dbus-glib-native freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf" |
| 6 | |
| 7 | inherit xfce gtk-doc |
| 8 | |
| 9 | SRC_URI[md5sum] = "dd5f9bae6a2470eb5fff0dc9edd3ea09" |
| 10 | SRC_URI[sha256sum] = "4e27a59694b0a5cc69ebccbdb00c724e670b5b7c30bc4dc0b461aac93f234fac" |
| 11 | SRC_URI += "file://0001-configure-use-pkg-config-for-freetype2.patch" |
| 12 | |
| 13 | INSANE_SKIP_${PN} = "dev-so" |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 17 | |
| 18 | do_install_append() { |
| 19 | # Makefile seems to race on creation of symlink. So ensure creation here |
| 20 | # until fixed properly |
| 21 | ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so |
| 22 | } |
| 23 | |
| 24 | FILES_${PN} += "${datadir}/dbus-1/services \ |
| 25 | ${libdir}/tumbler-1/tumblerd \ |
| 26 | ${libdir}/tumbler-1/plugins/*.so \ |
| 27 | ${libdir}/tumbler-1/plugins/cache/*.so \ |
| 28 | " |
| 29 | |
| 30 | FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ |
| 31 | ${libdir}/tumbler-1/plugins/cache/*.la" |
| 32 | FILES_${PN}-dbg += "${libdir}/tumbler-1/.debug \ |
| 33 | ${libdir}/tumbler-1/plugins/.debug \ |
| 34 | ${libdir}/tumbler-1/plugins/cache/.debug \ |
| 35 | " |