Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require gdb.inc |
| 2 | require gdb-${PV}.inc |
| 3 | |
| 4 | inherit python3-dir |
| 5 | |
| 6 | EXTRA_OEMAKE_append_libc-musl = "\ |
| 7 | gt_cv_func_gnugettext1_libc=yes \ |
| 8 | gt_cv_func_gnugettext2_libc=yes \ |
| 9 | gl_cv_func_gettimeofday_clobber=no \ |
| 10 | " |
| 11 | |
| 12 | do_configure_prepend() { |
| 13 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 14 | cat > ${WORKDIR}/python << EOF |
| 15 | #!/bin/sh |
| 16 | case "\$2" in |
| 17 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; |
| 18 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; |
| 19 | --exec-prefix) echo "${exec_prefix}" ;; |
| 20 | *) exit 1 ;; |
| 21 | esac |
| 22 | exit 0 |
| 23 | EOF |
| 24 | chmod +x ${WORKDIR}/python |
| 25 | fi |
| 26 | } |
| 27 | CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday" |