Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require go-${PV}.inc |
2 | require go-target.inc | ||||
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 3 | |
4 | export GO_TARGET_INSTALL = "cmd" | ||||
5 | export GO_FLAGS = "-a" | ||||
6 | export CC_FOR_TARGET = "${CC}" | ||||
7 | export CXX_FOR_TARGET = "${CXX}" | ||||
8 | |||||
9 | do_compile() { | ||||
10 | export GOBIN="${B}/bin" | ||||
11 | export TMPDIR="$GOTMPDIR" | ||||
12 | export CC=$BUILD_CC | ||||
13 | |||||
14 | cd src | ||||
15 | ./make.bash | ||||
16 | cd ${B} | ||||
17 | } |