blob: 0487c5f305933748f797c9d85c1a923789257654 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
12 file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \
13 file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \
14 file://threaded-xz.patch \
15"
16SRC_URI_append_class-native = " file://tar_ignore_error.patch"
17UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
18
19
20SRC_URI[md5sum] = "391c1c80aca26961375dd22e1d2d0cbf"
21SRC_URI[sha256sum] = "26b3f4dd1c1ef65f519d4cddfb35ebea41ae8af989aea2699a39783598c33769"
22
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25# For native builds we use the host Python
26PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
27PYTHONRDEPS_class-native = ""
28
29PACKAGECONFIG = "python update-alternatives"
30PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
31PACKAGECONFIG[update-alternatives] = ",,,"
32
33do_install() {
34 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
35 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
36 rm -f "${D}${bindir}/update-alternatives"
37 fi
38
39 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
40 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
41 fi
42}
43
44do_install_append_class-target() {
45 if [ -e "${D}${bindir}/update-alternatives" ]; then
46 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
47 fi
48}
49
50# These are empty and will pull python3-dev into images where it wouldn't
51# have been otherwise, so don't generate them.
52PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
53
54PACKAGES =+ "update-alternatives-opkg"
55FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
56RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
57RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
58RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
59
60pkg_postrm_update-alternatives-opkg() {
61 rm -rf $D${nonarch_libdir}/opkg/alternatives
62 rmdir $D${nonarch_libdir}/opkg || true
63}
64
65BBCLASSEXTEND = "native nativesdk"
66
67CLEANBROKEN = "1"