Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame^] | 10 | LICENSE = "GPLv2 & LGPLv2.1+" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = " \ |
| 12 | file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \ |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame^] | 13 | file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 14 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | SECTION = "base" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 16 | DEPENDS = "lzo util-linux zlib" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | DEPENDS_append_class-target = " udev" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \ |
| 20 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ |
| 21 | " |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame^] | 22 | SRCREV = "96d77fcefdd3b9fd297b5aabbce6dc43e2315ee2" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 25 | PACKAGECONFIG ??= " \ |
| 26 | programs \ |
| 27 | convert \ |
| 28 | python \ |
| 29 | crypto-builtin \ |
| 30 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 32 | PACKAGECONFIG[programs] = "--enable-programs,--disable-programs" |
| 33 | PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame^] | 34 | PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native" |
| 36 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
| 37 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 38 | # Pick only one crypto provider |
| 39 | PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin" |
| 40 | PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt" |
| 41 | PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium" |
| 42 | PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi" |
| 43 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | inherit autotools-brokensep pkgconfig manpages |
| 45 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)} |
| 46 | |
| 47 | CLEANBROKEN = "1" |
| 48 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 49 | EXTRA_OECONF = "--enable-largefile" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | EXTRA_OECONF_append_libc-musl = " --disable-backtrace " |
| 51 | EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}" |
| 52 | EXTRA_PYTHON_CFLAGS_class-native = "" |
| 53 | EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}" |
| 54 | EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'" |
| 55 | |
| 56 | do_configure_prepend() { |
| 57 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 58 | mkdir -p ${S}/config |
| 59 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 60 | } |
| 61 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | |
| 63 | do_install_append() { |
| 64 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 65 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python |
| 66 | fi |
| 67 | } |
| 68 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 69 | RDEPENDS_${PN} = "libgcc" |
| 70 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 71 | BBCLASSEXTEND = "native nativesdk" |