blob: d22380eb0df2df1865bfdf13b3ea08ade3b2dc4d [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06002
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003SECTION = "x11/network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop996bc452019-12-02 13:05:15 -05006DEPENDS = "python3 virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Brad Bishop996bc452019-12-02 13:05:15 -05008inherit autotools gettext pkgconfig gconf perlnative python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI = "\
11 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
12 file://sanitize-configure.ac.patch \
13 file://purple-OE-branding-25.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014 file://0001-configure.ac-fix-build-with-autoconf-2.71.patch \
15 file://0002-configure.ac-disable-few-languages-not-compatible-wi.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016"
17
Andrew Geisslerac970dd2021-02-12 15:32:45 -060018SRC_URI[sha256sum] = "f132e18d551117d9e46acce29ba4f40892a86746c366999166a3862b51060780"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
22"
23PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
24# --disable-gstreamer compile without GStreamer audio support
25# --disable-gstreamer-video
26# compile without GStreamer 1.0 Video Overlay support
27# --disable-gstreamer-interfaces
28# compile without GStreamer 0.10 interface support
29# --with-gstreamer=<version>
30# compile with GStreamer 0.10 or 1.0 interface
31PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
32PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
33PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
34PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
35PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
36PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060037PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,libgnt"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
39PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
40PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
41PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
42
43EXTRA_OECONF = " \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060044 --with-python=python3 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045 --disable-perl \
46 --disable-tcl \
47 --disable-gevolution \
48 --disable-schemas-install \
49 --disable-gtkspell \
50 --disable-meanwhile \
51 --disable-nm \
52 --disable-screensaver \
53"
54
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
56OE_LT_RPATH_ALLOW[export]="1"
57
Andrew Geisslerac970dd2021-02-12 15:32:45 -060058PACKAGES =+ "libpurple-dev libpurple finch finch-dev ${PN}-data"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059
Andrew Geisslerac970dd2021-02-12 15:32:45 -060060RPROVIDES_${PN}-dbg += "libpurple-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061
62LEAD_SONAME = "libpurple.so.0"
63FILES_libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
64FILES_libpurple-dev = "${libdir}/libpurple*.la \
65 ${libdir}/libpurple*.so \
66 ${libdir}/purple-2/*.la \
67 ${libdir}/purple-2/libjabber.so \
68 ${libdir}/purple-2/liboscar.so \
69 ${libdir}/purple-2/libymsg.so \
70 ${datadir}/aclocal"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050071FILES_finch = "${bindir}/finch"
72FILES_finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050073
74FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
75 ${datadir}/applications"
76RRECOMMENDS_${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
77
78FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
79FILES_${PN}-dev += "${libdir}/${PN}/*.la"
80
81PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
82
83python populate_packages_prepend () {
84 pidgroot = d.expand('${libdir}/pidgin')
85 purple = d.expand('${libdir}/purple-2')
86 finch = d.expand('${libdir}/finch')
87
88 do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$',
89 output_pattern='pidgin-plugin-%s',
90 description='Pidgin plugin %s',
91 prepend=True, extra_depends='')
92
93 do_split_packages(d, purple, '^lib(.*)\.so$',
94 output_pattern='libpurple-protocol-%s',
95 description='Libpurple protocol plugin for %s',
96 prepend=True, extra_depends='')
97
98 do_split_packages(d, purple, '^(ssl-.*)\.so$',
99 output_pattern='libpurple-plugin-%s',
100 description='libpurple plugin %s',
101 prepend=True, extra_depends='libpurple-plugin-ssl')
102
103 do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
104 output_pattern='libpurple-plugin-%s',
105 description='libpurple plugin %s',
106 prepend=True, extra_depends='')
107
108 do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$',
109 output_pattern='finch-plugin-%s',
110 description='Finch plugin %s',
111 prepend=True, extra_depends='')
112}