Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "USB hub per-port power control" |
| 2 | HOMEPAGE = "https://github.com/mvp/uhubctl" |
| 3 | BUGTRACKER = "https://github.com/mvp/uhubctl/issues" |
| 4 | DEPENDS = "libusb1" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 9 | SRCREV = "1b52efddbd68b4395df3ac9cd10eeb984af22439" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | SRC_URI = "git://github.com/mvp/${BPN}" |
| 11 | S = "${WORKDIR}/git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | # uhubctl gets its program version from "git describe". As we use the source |
| 14 | # archive do reduce download size replace the call with our hardcoded version. |
| 15 | do_configure_append() { |
| 16 | sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile |
| 17 | } |
| 18 | |
| 19 | do_install () { |
| 20 | oe_runmake install DESTDIR=${D} |
| 21 | } |