Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" |
| 2 | DESCRIPTION = "\ |
| 3 | The PyMongo distribution contains tools for interacting with MongoDB \ |
| 4 | database from Python. The bson package is an implementation of the BSON \ |
| 5 | format for Python. The pymongo package is a native Python driver for \ |
| 6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." |
| 7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 10 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 11 | SRC_URI[sha256sum] = "db5098587f58fbf8582d9bda2462762b367207246d3e19623782fb449c3c5fcc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | PACKAGES =+ "${PYTHON_PN}-bson" |
| 16 | |
| 17 | FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" |
| 18 | |
| 19 | RDEPENDS_${PYTHON_PN}-bson += " \ |
| 20 | ${PYTHON_PN}-datetime \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-netclient \ |
| 23 | ${PYTHON_PN}-numbers \ |
| 24 | ${PYTHON_PN}-threading \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS_${PN} += " \ |
| 28 | ${PYTHON_PN}-bson \ |
| 29 | ${PYTHON_PN}-pprint \ |
| 30 | " |