Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
| 12 | LICENSE = "Intel | BSD | GPLv2" |
| 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=6adbcb81e9ee6ae50c569b94fe12f7c5" |
| 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "df6bb667c60577c89df5abe3270539c1b9716b69409d1074d6a7fc5c2fea087b" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 23 | |
| 24 | S = "${WORKDIR}/acpica-unix-${PV}" |
| 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_PRIORITY = "100" |
| 29 | ALTERNATIVE_${PN} = "acpixtract acpidump" |
| 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 32 | OPT_CFLAGS=-Wall \ |
| 33 | DESTDIR=${D} \ |
| 34 | PREFIX=${prefix} \ |
| 35 | INSTALLDIR=${bindir} \ |
| 36 | INSTALLFLAGS= \ |
| 37 | " |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake install |
| 41 | } |
| 42 | |
| 43 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 44 | PROVIDES = "iasl" |
| 45 | RPROVIDES_${PN} += "iasl" |
| 46 | RREPLACES_${PN} += "iasl" |
| 47 | RCONFLICTS_${PN} += "iasl" |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |