Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Disk partition editing/resizing utility" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" |
| 3 | LICENSE = "GPLv3+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c" |
| 5 | SECTION = "console/tools" |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 6 | DEPENDS = "ncurses util-linux virtual/libiconv" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \ |
| 9 | file://no_check.patch \ |
| 10 | file://fix-doc-mandir.patch \ |
| 11 | file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \ |
| 12 | file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \ |
| 13 | file://run-ptest \ |
| 14 | file://0001-libparted-fs-add-sourcedir-lib-to-include-paths.patch \ |
| 15 | file://0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "090655d05f3c471aa8e15a27536889ec" |
| 19 | SRC_URI[sha256sum] = "57e2b4bd87018625c515421d4524f6e3b55175b472302056391c5f7eccb83d44" |
| 20 | |
| 21 | EXTRA_OECONF = "--disable-device-mapper" |
| 22 | |
| 23 | inherit autotools pkgconfig gettext texinfo ptest |
| 24 | |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 25 | PACKAGECONFIG ?= "readline" |
| 26 | PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline" |
| 27 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 28 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | do_compile_ptest() { |
| 31 | oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags |
| 32 | } |
| 33 | |
| 34 | do_install_ptest() { |
| 35 | t=${D}${PTEST_PATH} |
| 36 | mkdir $t/build-aux |
| 37 | cp ${S}/build-aux/test-driver $t/build-aux/ |
| 38 | cp -r ${S}/tests $t |
| 39 | cp ${B}/tests/Makefile $t/tests/ |
| 40 | sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile |
| 41 | sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile |
| 42 | sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile |
| 43 | sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile |
| 44 | sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile |
| 45 | for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \ |
| 46 | do cp ${B}/tests/.libs/$i $t/tests/; \ |
| 47 | done |
| 48 | sed -e 's| ../parted||' -i $t/tests/*.sh |
| 49 | } |
| 50 | |
| 51 | RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs" |
Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 52 | RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 53 | RDEPENDS_${PN}-ptest_append_libc-glibc = "\ |
| 54 | glibc-utils \ |
| 55 | locale-base-en-us \ |
| 56 | " |
| 57 | |
| 58 | inherit update-alternatives |
| 59 | |
| 60 | ALTERNATIVE_PRIORITY = "100" |
| 61 | ALTERNATIVE_${PN} = "partprobe" |
| 62 | ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe" |