blob: ce40c04ad4b69f3acf5b675d5f104d645cb7ba5c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
Andrew Geisslerc723b722021-01-08 16:14:09 -06006DEPENDS = "ncurses util-linux virtual/libiconv"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
9 file://no_check.patch \
10 file://fix-doc-mandir.patch \
11 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
12 file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \
13 file://run-ptest \
14 file://0001-libparted-fs-add-sourcedir-lib-to-include-paths.patch \
15 file://0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch \
16 "
17
18SRC_URI[md5sum] = "090655d05f3c471aa8e15a27536889ec"
19SRC_URI[sha256sum] = "57e2b4bd87018625c515421d4524f6e3b55175b472302056391c5f7eccb83d44"
20
21EXTRA_OECONF = "--disable-device-mapper"
22
23inherit autotools pkgconfig gettext texinfo ptest
24
Andrew Geisslerc723b722021-01-08 16:14:09 -060025PACKAGECONFIG ?= "readline"
26PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
27
Andrew Geissler5a43b432020-06-13 10:46:56 -050028BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30do_compile_ptest() {
31 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
32}
33
34do_install_ptest() {
35 t=${D}${PTEST_PATH}
36 mkdir $t/build-aux
37 cp ${S}/build-aux/test-driver $t/build-aux/
38 cp -r ${S}/tests $t
39 cp ${B}/tests/Makefile $t/tests/
40 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
41 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
42 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
43 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
44 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
45 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
46 do cp ${B}/tests/.libs/$i $t/tests/; \
47 done
48 sed -e 's| ../parted||' -i $t/tests/*.sh
49}
50
51RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs"
Andrew Geisslerf0343792020-11-18 10:42:21 -060052RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
Andrew Geissler82c905d2020-04-13 13:39:40 -050053RDEPENDS_${PN}-ptest_append_libc-glibc = "\
54 glibc-utils \
55 locale-base-en-us \
56 "
57
58inherit update-alternatives
59
60ALTERNATIVE_PRIORITY = "100"
61ALTERNATIVE_${PN} = "partprobe"
62ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"