Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 7 | |
| 8 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "e19d0f760b353e88161b3712193cffbd79bf1314418da792b5fec4d8ecef389c" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 10 | |
| 11 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 12 | RDEPENDS_${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 13 | |
| 14 | PNREAL = "gst-python" |
| 15 | |
| 16 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 17 | |
| 18 | # gobject-introspection is mandatory and cannot be configured |
| 19 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 20 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| 21 | |
| 22 | inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check |