Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for tracing OpenGL, Direct3D, and other graphics APIs" |
| 2 | HOMEPAGE = "http://apitrace.github.io/" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "MIT & BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50 \ |
| 6 | file://thirdparty/snappy/COPYING;md5=f62f3080324a97b3159a7a7e61812d0c" |
| 7 | |
| 8 | SRCREV = "cae55f54c53449fd07f8a917dcd0874db2c15032" |
| 9 | SRC_URI = "git://github.com/${BPN}/${BPN}.git" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | DEPENDS += "zlib libpng python3-native" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | EXTRA_OECMAKE += "\ |
| 18 | -DENABLE_GUI=OFF \ |
| 19 | -DENABLE_X11=OFF \ |
| 20 | -DENABLE_STATIC_LIBGCC=OFF \ |
| 21 | -DENABLE_STATIC_LIBSTDCXX=OFF \ |
| 22 | -DPython3_ROOT_DIR=/usr/bin/python3-native \ |
| 23 | " |
| 24 | |
| 25 | # Use the bundled snappy library |
| 26 | EXTRA_OECMAKE += "\ |
| 27 | -DENABLE_STATIC_SNAPPY=ON \ |
| 28 | " |
| 29 | |
| 30 | SECURITY_CFLAGS_toolchain-clang = "" |