Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 1 | SUMMARY = "Install a Debian system into a subdirectory" |
| 2 | HOMEPAGE = "https://wiki.debian.org/Debootstrap" |
| 3 | SECTION = "devel" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_${PV}.tar.gz \ |
| 9 | file://0001-support-to-override-usr-sbin-and-usr-share.patch \ |
| 10 | file://0002-support-to-override-usr-bin-arch-test.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "b959c7ac01839e9b96a733d27b19e59e" |
| 14 | SRC_URI[sha256sum] = "5e5a8147ecdd6be0eea5ac4d6ed8192cc653e93f744dd3306c9b1cc51d6ca328" |
| 15 | |
| 16 | S = "${WORKDIR}/debootstrap" |
| 17 | |
| 18 | fakeroot do_install() { |
| 19 | oe_runmake 'DESTDIR=${D}' install |
| 20 | chown -R root:root ${D}${datadir}/debootstrap |
| 21 | } |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |