Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
| 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | file://0001-tiffset-fix-global-buffer-overflow-for-ASCII-tags-wh.patch \ |
| 13 | file://561599c99f987dc32ae110370cfdd7df7975586b.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | file://eecb0712f4c3a5b449f70c57988260a667ddbdef.patch \ |
| 15 | file://0001-tif_jbig.c-fix-crash-when-reading-a-file-with-multip.patch \ |
| 16 | file://0002-tiffcrop-fix-issue-380-and-382-heap-buffer-overflow-.patch \ |
| 17 | file://0003-add-checks-for-return-value-of-limitMalloc-392.patch \ |
| 18 | file://0004-TIFFFetchNormalTag-avoid-calling-memcpy-with-a-null-.patch \ |
| 19 | file://0005-fix-the-FPE-in-tiffcrop-393.patch \ |
| 20 | file://0006-fix-heap-buffer-overflow-in-tiffcp-278.patch \ |
| 21 | " |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 22 | |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 23 | SRC_URI[sha256sum] = "0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | # exclude betas |
| 26 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 27 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 28 | # Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 |
| 29 | # and 4.3.0 doesn't have the issue |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 30 | CVE_CHECK_IGNORE += "CVE-2015-7313" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 31 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | inherit autotools multilib_header |
| 33 | |
| 34 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 35 | |
| 36 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 37 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 38 | |
| 39 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 40 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 41 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 42 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 43 | |
| 44 | # Convert single-strip uncompressed images to multiple strips of specified |
| 45 | # size (default: 8192) to reduce memory usage |
| 46 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 47 | |
| 48 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 49 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 50 | |
| 51 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 52 | # the tag |
| 53 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 54 | |
| 55 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 56 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 57 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 58 | |
| 59 | PACKAGES =+ "tiffxx tiff-utils" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 60 | FILES:tiffxx = "${libdir}/libtiffxx.so.*" |
| 61 | FILES:tiff-utils = "${bindir}/*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 62 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 63 | do_install:append() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 64 | oe_multilib_header tiffconf.h |
| 65 | } |
| 66 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 67 | BBCLASSEXTEND = "native nativesdk" |