Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An example of partitioned image." |
| 2 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 3 | SRC_URI = "file://${FILE_DIRNAME}/${BPN}.wks" |
| 4 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}" |
| 6 | |
| 7 | IMAGE_FSTYPES = "wic.bz2" |
| 8 | RM_OLD_IMAGE = "1" |
| 9 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 10 | DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-native" |
| 11 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | # core-image-minimal is referenced in .wks, so we need its rootfs |
| 13 | # to be ready before our rootfs |
| 14 | do_rootfs[depends] += "core-image-minimal:do_rootfs" |
| 15 | |
| 16 | IMAGE_ROOTFS_EXTRA_SPACE = "2000" |
| 17 | |
| 18 | inherit image |