Brad Bishop | 8fffc16 | 2016-08-19 09:02:54 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - IPMI providers" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | inherit obmc-phosphor-license |
| 6 | |
| 7 | PROVIDES = "${PACKAGES}" |
| 8 | PACKAGES = "${PN}-libs" |
| 9 | |
Tom Joseph | 1562bbc | 2017-02-20 12:01:43 +0530 | [diff] [blame] | 10 | OBMC_IPMID_PROVIDERS = "phosphor-ipmi-fru" |
| 11 | |
Brad Bishop | 8fffc16 | 2016-08-19 09:02:54 -0500 | [diff] [blame] | 12 | SUMMARY_${PN}-libs = "Extra providers for ipmid." |
Tom Joseph | 1562bbc | 2017-02-20 12:01:43 +0530 | [diff] [blame] | 13 | RDEPENDS_${PN}-libs = "${OBMC_IPMID_PROVIDERS}" |
| 14 | |
| 15 | WHITELIST_FORMAT = "{0}-whitelist-native" |
| 16 | OBMC_IPMID_WHITELISTS = "${@compose_list(d, 'WHITELIST_FORMAT', 'OBMC_IPMID_PROVIDERS')}" |
| 17 | |
Tom Joseph | ae46d56 | 2017-02-24 01:06:54 -0600 | [diff] [blame^] | 18 | DEPENDS_append = "${OBMC_IPMID_WHITELISTS}" |
| 19 | |
| 20 | # Normally the dependency is between do_configure and |
| 21 | # DEPENDS:do_populate_sysroot, but when a package is in the SSTATE cache the |
| 22 | # do_configure step is not re-ran. The do_populate_sysroot tasks can themselves |
| 23 | # be performed in parallel by bitbake. |
| 24 | # Since the do_populate_sysroot task of this recipe doesn't provide the |
| 25 | # whitelists itself, we need an explicit dependency on the whitelist's |
| 26 | # do_populate_sysroot task so that the whitelists are present in time for an |
| 27 | # application that needs them to be do_configured. |
| 28 | |
| 29 | WHITELIST_TASK_FORMAT = "{0}:do_populate_sysroot" |
| 30 | do_populate_sysroot[depends] = "${@compose_list(d, 'WHITELIST_TASK_FORMAT', 'OBMC_IPMID_WHITELISTS')}" |