Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Utilities and libraries for handling compiled object files" |
| 2 | HOMEPAGE = "https://sourceware.org/elfutils" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "(GPLv3 & Elfutils-Exception)" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" |
| 7 | DEPENDS_append_libc-musl = " argp-standalone fts " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | # The Debian patches below are from: |
| 9 | # http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.168-0.2.debian.tar.xz |
| 10 | SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \ |
| 11 | file://0001-dso-link-change.patch \ |
| 12 | file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \ |
| 13 | file://0003-fixheadercheck.patch \ |
| 14 | file://0004-Disable-the-test-to-convert-euc-jp.patch \ |
| 15 | file://0005-fix-a-stack-usage-warning.patch \ |
| 16 | file://0006-Fix-build-on-aarch64-musl.patch \ |
| 17 | file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \ |
| 18 | file://0001-libasm-may-link-with-libbz2-if-found.patch \ |
| 19 | file://debian/hppa_backend.diff \ |
| 20 | file://debian/arm_backend.diff \ |
| 21 | file://debian/mips_backend.patch \ |
| 22 | file://debian/mips_readelf_w.patch \ |
| 23 | file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \ |
| 24 | file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \ |
| 25 | file://debian/0003-Add-mips-n64-relocation-format-hack.patch \ |
| 26 | file://0001-Use-fallthrough-attribute.patch \ |
| 27 | file://0001-Ensure-that-packed-structs-follow-the-gcc-memory-lay.patch \ |
| 28 | " |
| 29 | SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | SRC_URI[md5sum] = "03599aee98c9b726c7a732a2dd0245d5" |
| 31 | SRC_URI[sha256sum] = "1f844775576b79bdc9f9c717a50058d08620323c1e935458223a12f249c9e066" |
| 32 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | inherit autotools gettext |
| 34 | |
| 35 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" |
| 36 | EXTRA_OECONF_append_class-native = " --without-bzlib" |
| 37 | |
| 38 | do_install_append() { |
| 39 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then |
| 40 | rm -f ${D}${bindir}/eu-objdump |
| 41 | fi |
| 42 | } |
| 43 | |
| 44 | EXTRA_OEMAKE_class-native = "" |
| 45 | EXTRA_OEMAKE_class-nativesdk = "" |
| 46 | |
| 47 | ALLOW_EMPTY_${PN}_libc-musl = "1" |
| 48 | |
| 49 | BBCLASSEXTEND = "native nativesdk" |
| 50 | |
| 51 | # Package utilities separately |
| 52 | PACKAGES =+ "${PN}-binutils libelf libasm libdw" |
| 53 | FILES_${PN}-binutils = "\ |
| 54 | ${bindir}/eu-addr2line \ |
| 55 | ${bindir}/eu-ld \ |
| 56 | ${bindir}/eu-nm \ |
| 57 | ${bindir}/eu-readelf \ |
| 58 | ${bindir}/eu-size \ |
| 59 | ${bindir}/eu-strip" |
| 60 | |
| 61 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" |
| 62 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" |
| 63 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" |
| 64 | # Some packages have the version preceeding the .so instead properly |
| 65 | # versioned .so.<version>, so we need to reorder and repackage. |
| 66 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" |
| 67 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" |
| 68 | |
| 69 | # The package contains symlinks that trip up insane |
| 70 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" |