Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Build Result Compare Script" |
| 2 | DESCRIPTION = "This package contains scripts to find out if the build result\ |
| 3 | differs to a former build." |
| 4 | HOMEPAGE = "https://github.com/openSUSE/build-compare" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/openSUSE/build-compare.git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | # Date matches entry in build-compare.changes and date of SRCREV. |
| 11 | # |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 12 | SRCREV = "102d844ce052c6dec6c56ee1d471bde72a1b4633" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | PE = "1" |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 14 | PV = "2020.05.29+git${SRCPV}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}/${bindir} |
| 23 | install -m 755 functions.sh ${D}/${bindir} |
| 24 | install -m 755 pkg-diff.sh ${D}/${bindir} |
| 25 | install -m 755 same-build-result.sh ${D}/${bindir} |
| 26 | install -m 755 srpm-check.sh ${D}/${bindir} |
| 27 | } |
| 28 | |
| 29 | RDEPENDS_${PN} += "bash" |