Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Different utilities from Android - corressponding configuration files for using ConfigFS" |
| 2 | SECTION = "console/utils" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | file://android-gadget-setup \ |
| 8 | file://android-gadget-start \ |
| 9 | file://android-gadget-cleanup \ |
| 10 | file://10-adbd-configfs.conf \ |
| 11 | " |
| 12 | |
| 13 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 14 | |
| 15 | do_install() { |
| 16 | install -d ${D}${bindir} |
| 17 | install -m 0755 ${WORKDIR}/android-gadget-setup ${D}${bindir} |
| 18 | install -m 0755 ${WORKDIR}/android-gadget-start ${D}${bindir} |
| 19 | install -m 0755 ${WORKDIR}/android-gadget-cleanup ${D}${bindir} |
| 20 | |
| 21 | if [ -r ${WORKDIR}/android-gadget-setup.machine ] ; then |
| 22 | install -d ${D}${sysconfdir} |
| 23 | install -m 0644 ${WORKDIR}/android-gadget-setup.machine ${D}${sysconfdir} |
| 24 | fi |
| 25 | |
| 26 | install -d ${D}${systemd_unitdir}/system/android-tools-adbd.service.d |
| 27 | install -m 0644 ${WORKDIR}/10-adbd-configfs.conf ${D}${systemd_unitdir}/system/android-tools-adbd.service.d |
| 28 | } |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN} += " \ |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 31 | ${systemd_unitdir}/system/ \ |
| 32 | " |
| 33 | |
| 34 | PROVIDES += "android-tools-conf" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | RPROVIDES:${PN} = "android-tools-conf" |