Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Header-only C++ library for JSON Schema validation" |
| 2 | HOMEPAGE = "https://github.com/tristanpenman/valijson" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=015106c62262b2383f6c72063f0998f2" |
| 5 | |
| 6 | SRC_URI = "git://github.com/tristanpenman/valijson.git;branch=master;protocol=https" |
| 7 | SRCREV = "2dfc7499a31b84edef71189f4247919268ebc74e" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit cmake |
| 12 | |
| 13 | PACKAGECONFIG ?= "boost" |
| 14 | |
| 15 | PACKAGECONFIG[boost] = "-Dvalijson_EXCLUDE_BOOST=FALSE,-Dvalijson_EXCLUDE_BOOST=TRUE,boost" |
| 16 | PACKAGECONFIG[examples] = "-Dvalijson_BUILD_EXAMPLES=TRUE,-Dvalijson_BUILD_EXAMPLES=FALSE,curlpp" |
| 17 | PACKAGECONFIG[tests] = "-Dvalijson_BUILD_TESTS=TRUE,-Dvalijson_BUILD_TESTS=FALSE,curlpp" |
| 18 | |
| 19 | # valijson is a header only C++ library, so the main package will be empty. |
| 20 | RDEPENDS:${PN}-dev = "" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${includedir}/compat |
| 26 | install -d ${D}${includedir}/valijson |
| 27 | install -d ${D}${includedir}/valijson/adapters |
| 28 | install -d ${D}${includedir}/valijson/constraints |
| 29 | install -d ${D}${includedir}/valijson/internal |
| 30 | install -d ${D}${includedir}/valijson/utils |
| 31 | |
| 32 | install -m 0644 ${S}/include/compat/* ${D}${includedir}/compat |
| 33 | install -D -m 0644 ${S}/include/valijson/*.hpp -t ${D}${includedir}/valijson |
| 34 | install -D -m 0644 ${S}/include/valijson/adapters/*.hpp -t ${D}${includedir}/valijson/adapters |
| 35 | install -D -m 0644 ${S}/include/valijson/constraints/*.hpp -t ${D}${includedir}/valijson/constraints |
| 36 | install -D -m 0644 ${S}/include/valijson/internal/*.hpp -t ${D}${includedir}/valijson/internal |
| 37 | install -D -m 0644 ${S}/include/valijson/utils/*.hpp -t ${D}${includedir}/valijson/utils |
| 38 | } |