Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPLv3+" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=8fe0fdfdc7a892516526b86c28d06a16" |
| 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | |
| 14 | SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz" |
| 15 | SRC_URI[sha256sum] = "f0d3cff5d555d6868f14a7d05696f0370074e475304fd5aa152b98f892364981" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/" |
| 18 | |
| 19 | inherit cmake |
| 20 | |
| 21 | PATCHTOOL = "patch" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
| 24 | |
| 25 | PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| 26 | PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |