blob: c608077dee3f9e52f088bf22bab2b5d6c19bd91f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Interactive process viewer"
2HOMEPAGE = "http://hisham.hm/htop"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \
Brad Bishop996bc452019-12-02 13:05:15 -050010 file://0001-Use-pkg-config.patch \
11 file://0001-Ask-for-python3-specifically.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050012 file://htop-gcc10.patch \
Brad Bishop996bc452019-12-02 13:05:15 -050013 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014SRC_URI[md5sum] = "0d816b6beed31edc75babcfbf863ffa8"
15SRC_URI[sha256sum] = "d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57"
16
17inherit autotools pkgconfig
18
19PACKAGECONFIG ??= "proc \
20 cgroup \
21 taskstats \
22 unicode \
23 linux-affinity \
24 delayacct"
25PACKAGECONFIG[proc] = "--enable-proc,--disable-proc"
26PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
27PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup"
28PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
29PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats"
30PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
31PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity"
32PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc"
33PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid"
34PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
35
36do_configure_prepend () {
37 rm -rf ${S}/config.h
38}