Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap" |
| 2 | DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \ |
| 3 | bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \ |
| 4 | and copying files using the block map. The idea is that large file containing \ |
| 5 | unused blocks, like raw system image files, can be copied or flashed a lot \ |
| 6 | faster with bmaptool than with traditional tools like "dd" or "cp"." |
| 7 | HOMEPAGE = "https://github.com/01org/bmap-tools" |
| 8 | SECTION = "console/utils" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | SRC_URI = "https://github.com/intel/${BPN}/releases/download/v${PV}/${BP}.tgz" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "883420183611aa137cbaf68a91ef0d7e" |
| 15 | SRC_URI[sha256sum] = "0064891270c180c190f41925b0f6fb9cecac3056f1168d2592dbe90e5f226c0a" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/intel/${BPN}/releases" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 19 | RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | |
| 21 | inherit python3native |
| 22 | inherit setuptools3 |
| 23 | |
| 24 | BBCLASSEXTEND = "native" |