Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Skip tests when modules not available" |
| 2 | DESCRIPTION = "Skip test scripts if modules are not available. \ |
| 3 | The requested modules will be loaded, and optionally have their versions \ |
| 4 | checked. If the module is missing, the test script will be skipped. Modules \ |
| 5 | that are found but fail to compile will exit with an error rather than skip." |
| 6 | |
| 7 | HOMEPAGE = "https://metacpan.org/release/Test-Needs" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 10 | |
| 11 | CPAN_NAME = "Test-Needs" |
| 12 | CPAN_AUTHOR = "HAARG" |
| 13 | |
| 14 | LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=81;endline=82" |
| 15 | |
| 16 | DEPENDS += "perl" |
| 17 | |
| 18 | SRC_URI = "http://www.cpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz" |
| 19 | |
| 20 | SRC_URI[md5sum] = "356634a56c99282e8059f290f5d534c8" |
| 21 | SRC_URI[sha256sum] = "5a4f33983586edacdbe00a3b429a9834190140190dab28d0f873c394eb7df399" |
| 22 | |
| 23 | S = "${WORKDIR}/${CPAN_NAME}-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
| 27 | RDEPENDS_${PN}-ptest += "perl-module-test-more" |
| 28 | |
| 29 | BBCLASSEXTEND = "native" |