Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Hardware accelerated JPEG compression/decompression library" |
| 2 | DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression" |
| 3 | HOMEPAGE = "http://libjpeg-turbo.org/" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8184bcc7c4ac7b9edc6a7bc00f231d0b \ |
| 7 | file://jpeglib.h;endline=16;md5=f67d70e547a2662c079781c72f877f72 \ |
| 8 | file://djpeg.c;endline=11;md5=c59e19811c006cb38f82d6477134d314 \ |
| 9 | " |
| 10 | DEPENDS_append_x86-64_class-target = " nasm-native" |
| 11 | DEPENDS_append_x86_class-target = " nasm-native" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz" |
| 14 | |
| 15 | SRC_URI[md5sum] = "7c82f0f6a3130ec06b8a4d0b321cbca3" |
| 16 | SRC_URI[sha256sum] = "b24890e2bb46e12e72a79f7e965f409f4e16466d00e1dd15d93d73ee6b592523" |
| 17 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/" |
| 18 | UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/" |
| 19 | |
| 20 | PE= "1" |
| 21 | |
| 22 | # Drop-in replacement for jpeg |
| 23 | PROVIDES = "jpeg" |
| 24 | RPROVIDES_${PN} += "jpeg" |
| 25 | RREPLACES_${PN} += "jpeg" |
| 26 | RCONFLICTS_${PN} += "jpeg" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | # Add nasm-native dependency consistently for all build arches is hard |
| 31 | EXTRA_OECONF_append_class-native = " --without-simd" |
| 32 | |
| 33 | # Work around missing x32 ABI support |
| 34 | EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--without-simd", "", d)}" |
| 35 | |
| 36 | # Work around missing non-floating point ABI support in MIPS |
| 37 | EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "--without-simd", "", d)}" |
| 38 | |
| 39 | # Provide a workaround if Altivec unit is not present in PPC |
| 40 | EXTRA_OECONF_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}" |
| 41 | EXTRA_OECONF_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}" |
| 42 | |
| 43 | def get_build_time(d): |
| 44 | if d.getVar('SOURCE_DATE_EPOCH') != None: |
| 45 | import datetime |
| 46 | return " --with-build-date="+ datetime.datetime.fromtimestamp(float(d.getVar('SOURCE_DATE_EPOCH'))).strftime("%Y%m%d") |
| 47 | return "" |
| 48 | |
| 49 | EXTRA_OECONF_append_class-target = "${@get_build_time(d)}" |
| 50 | |
| 51 | PACKAGES =+ "jpeg-tools libturbojpeg" |
| 52 | |
| 53 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." |
| 54 | FILES_jpeg-tools = "${bindir}/*" |
| 55 | |
| 56 | DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" |
| 57 | FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*" |
| 58 | |
| 59 | BBCLASSEXTEND = "native" |