Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Wayland, a protocol between a compositor and clients" |
| 2 | DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \ |
| 3 | as well as a C library implementation of that protocol. The compositor can be \ |
| 4 | a standalone display server running on Linux kernel modesetting and evdev \ |
| 5 | input devices, an X application, or a wayland client itself. The clients can \ |
| 6 | be traditional applications, X servers (rootless or fullscreen) or other \ |
| 7 | display servers." |
| 8 | HOMEPAGE = "http://wayland.freedesktop.org" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \ |
| 11 | file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce" |
| 12 | |
| 13 | DEPENDS = "expat libxml2 libffi wayland-native" |
| 14 | |
| 15 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 16 | file://fixpathinpcfiles.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "0235f6075c32c3be61cff94fa0b9f108" |
| 19 | SRC_URI[sha256sum] = "ed80cabc0961a759a42092e2c39aabfc1ec9a13c86c98bbe2b812f008da27ab8" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | EXTRA_OECONF = "--disable-documentation --with-host-scanner" |
| 24 | EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries" |
| 25 | |
| 26 | # Wayland installs a M4 macro for other projects to use, which uses the target |
| 27 | # pkg-config to find files. Replace pkg-config with pkg-config-native. |
| 28 | do_install_append_class-native() { |
| 29 | sed -e 's,PKG_CHECK_MODULES(.*),,g' \ |
| 30 | -e 's,$PKG_CONFIG,pkg-config-native,g' \ |
| 31 | -i ${D}/${datadir}/aclocal/wayland-scanner.m4 |
| 32 | } |
| 33 | |
| 34 | sysroot_stage_all_append_class-target () { |
| 35 | rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4 |
| 36 | cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/ |
| 37 | } |
| 38 | |
| 39 | FILES_${PN} = "${libdir}/*${SOLIBS}" |
| 40 | FILES_${PN}-dev += "${bindir} ${datadir}/wayland" |
| 41 | |
| 42 | BBCLASSEXTEND = "native nativesdk" |