Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Advanced tools for certain ALSA sound card drivers" |
| 2 | HOMEPAGE = "http://www.alsa-project.org" |
| 3 | BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2 & LGPLv2+" |
| 6 | DEPENDS = "alsa-lib ncurses glib-2.0" |
| 7 | |
| 8 | LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 9 | file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 10 | |
| 11 | SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \ |
| 12 | file://autotools.patch \ |
| 13 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://makefile_no_gtk.patch', d)} \ |
| 14 | file://gitcompile_hdajacksensetest \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "3afb92eb1b4f2edc8691498e57c3ec78" |
| 18 | SRC_URI[sha256sum] = "bc3c6567de835223ee7d69487b8c22fb395a2e8c613341b0c96e6a5f6a2bd534" |
| 19 | |
| 20 | inherit autotools-brokensep pkgconfig |
| 21 | |
| 22 | CLEANBROKEN = "1" |
| 23 | |
| 24 | EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'" |
| 25 | |
| 26 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}" |
| 27 | PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3," |
| 28 | |
| 29 | # configure.ac/.in doesn't exist so force copy |
| 30 | AUTOTOOLS_COPYACLOCAL = "1" |
| 31 | |
| 32 | do_compile_prepend () { |
| 33 | #Automake dir is not correctly detected in cross compilation case |
| 34 | export AUTOMAKE_DIR="$(automake --print-libdir)" |
| 35 | export ACLOCAL_FLAGS="--system-acdir=${ACLOCALDIR}/ ${ACLOCALEXTRAPATH}" |
| 36 | |
| 37 | cp ${WORKDIR}/gitcompile_hdajacksensetest ${S}/hdajacksensetest/gitcompile |
| 38 | } |
| 39 | |
| 40 | FILES_${PN} += "${datadir}/ld10k1" |