Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "WebP is an image format designed for the Web" |
| 2 | DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \ |
| 3 | used on a large variety of photographic, translucent and \ |
| 4 | graphical images found on the web. The degree of lossy \ |
| 5 | compression is adjustable so a user can choose the trade-off \ |
| 6 | between file size and image quality. WebP typically achieves \ |
| 7 | an average of 30% more compression than JPEG and JPEG 2000, \ |
| 8 | without loss of image quality." |
| 9 | HOMEPAGE = "https://developers.google.com/speed/webp/" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | LICENSE = "BSD" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \ |
| 14 | file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7" |
| 15 | |
| 16 | SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz" |
| 17 | SRC_URI[md5sum] = "02c0c55f1dd8612cd4d462e3409ad35d" |
| 18 | SRC_URI[sha256sum] = "3d47b48c40ed6476e8047b2ddb81d93835e0ca1b8d3e8c679afbb3004dd564b1" |
| 19 | |
| 20 | UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html" |
| 21 | |
| 22 | EXTRA_OECONF = " \ |
| 23 | --disable-wic \ |
| 24 | --enable-libwebpmux \ |
| 25 | --enable-libwebpdemux \ |
| 26 | --enable-threading \ |
| 27 | " |
| 28 | # Do not trust configure to determine if neon is available. |
| 29 | # |
| 30 | EXTRA_OECONF_append_arm = " \ |
| 31 | ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \ |
| 32 | " |
| 33 | |
| 34 | inherit autotools lib_package |
| 35 | |
| 36 | PACKAGECONFIG ??= "" |
| 37 | |
| 38 | # libwebpdecoder is a subset of libwebp, don't build it unless requested |
| 39 | PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder" |
| 40 | |
| 41 | # Apply for examples programs: cwebp and dwebp |
| 42 | PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib" |
| 43 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 44 | PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng" |
| 45 | PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" |
| 46 | |
| 47 | # Apply only for example program vwebp |
| 48 | PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut" |
| 49 | |
| 50 | PACKAGES =+ "${PN}-gif2webp" |
| 51 | |
| 52 | DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP" |
| 53 | FILES_${PN}-gif2webp = "${bindir}/gif2webp" |