Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An alternate posix capabilities library" |
| 2 | DESCRIPTION = "The libcap-ng library is intended to make programming \ |
| 3 | with POSIX capabilities much easier than the traditional libcap library." |
| 4 | HOMEPAGE = "http://freecode.com/projects/libcap-ng" |
| 5 | SECTION = "base" |
| 6 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06" |
| 9 | |
| 10 | SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \ |
| 11 | file://python.patch" |
| 12 | |
| 13 | inherit lib_package autotools pythonnative |
| 14 | |
| 15 | SRC_URI[md5sum] = "3d7d126b29e2869a0257c17c8b0d9b2e" |
| 16 | SRC_URI[sha256sum] = "615549ce39b333f6b78baee0c0b4ef18bc726c6bf1cca123dfd89dd963f6d06b" |
| 17 | |
| 18 | DEPENDS += "swig-native python" |
| 19 | |
| 20 | EXTRA_OECONF += "--without-python3" |
| 21 | |
| 22 | EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'" |
| 23 | |
| 24 | PACKAGES += "${PN}-python" |
| 25 | |
| 26 | FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug" |
| 27 | FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}" |
| 28 | |
| 29 | BBCLASSEXTEND = "native" |
| 30 | |
| 31 | do_install_append() { |
| 32 | # Moving libcap-ng to base_libdir |
| 33 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then |
| 34 | mkdir -p ${D}/${base_libdir}/ |
| 35 | mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/ |
| 36 | relpath=${@os.path.relpath("${base_libdir}", "${libdir}")} |
| 37 | ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so |
| 38 | fi |
| 39 | } |