Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Character encoding support library" |
| 2 | DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \ |
| 3 | multiple character encodings, but that support lacks from your system." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/libiconv" |
| 5 | SECTION = "libs" |
| 6 | NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8" |
| 7 | PROVIDES = "virtual/libiconv" |
| 8 | |
| 9 | LICENSE = "LGPLv2.0" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674 \ |
| 11 | file://libcharset/COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674" |
| 12 | |
| 13 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ |
| 14 | file://autoconf.patch \ |
| 15 | file://shared_preloadable_libiconv_linux.patch \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "d42b97f6ef5dd0ba4469d520ed732fed" |
| 19 | SRC_URI[sha256sum] = "e78c347a1a0cb15f2648519e9799151f4b4a934b61ad9ee7424478efe2b8257f" |
| 20 | |
| 21 | S = "${WORKDIR}/libiconv-${PV}" |
| 22 | |
| 23 | inherit autotools pkgconfig gettext |
| 24 | |
| 25 | python __anonymous() { |
| 26 | if d.getVar("TCLIBC", True) == "glibc": |
| 27 | raise bb.parse.SkipPackage("libiconv is provided for use with uClibc only - glibc already provides iconv") |
| 28 | } |
| 29 | |
| 30 | EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable" |
| 31 | |
| 32 | LEAD_SONAME = "libiconv.so" |
| 33 | |
| 34 | do_configure_prepend () { |
| 35 | rm -f ${S}/m4/libtool.m4 ${S}/m4/ltoptions.m4 ${S}/m4/ltsugar.m4 ${S}/m4/ltversion.m4 ${S}/m4/lt~obsolete.m4 ${S}/libcharset/m4/libtool.m4 ${S}/libcharset/m4/ltoptions.m4 ${S}/libcharset/m4/ltsugar.m4 ${S}/libcharset/m4/ltversion.m4 ${S}/libcharset/m4/lt~obsolete.m4 |
| 36 | } |
| 37 | |
| 38 | do_configure_append () { |
| 39 | # forcibly remove RPATH from libtool |
| 40 | sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' *libtool |
| 41 | sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=_NO_RPATH_|g' *libtool |
| 42 | } |
| 43 | |
| 44 | do_install_append () { |
| 45 | rm -rf ${D}${libdir}/preloadable_libiconv.so |
| 46 | rm -rf ${D}${libdir}/charset.alias |
| 47 | } |