Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Portable Threads library" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/pth/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222cafd37f24370a77b1" |
| 6 | PR = "r3" |
| 7 | |
| 8 | python __anonymous () { |
| 9 | import re |
| 10 | uc_os = (re.match('.*uclibc*', d.getVar('TARGET_OS', True)) != None) |
| 11 | if uc_os: |
| 12 | raise bb.parse.SkipPackage("incompatible with uClibc") |
| 13 | } |
| 14 | |
| 15 | SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \ |
| 16 | file://pth-add-pkgconfig-support.patch \ |
| 17 | file://pth-fix-parallel.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "9cb4a25331a4c4db866a31cbe507c793" |
| 21 | SRC_URI[sha256sum] = "72353660c5a2caafd601b20e12e75d865fd88f6cf1a088b306a3963f0bc77232" |
| 22 | |
| 23 | BINCONFIG = "${bindir}/pth-config" |
| 24 | |
| 25 | inherit autotools binconfig-disabled pkgconfig |
| 26 | |
| 27 | do_configure() { |
| 28 | ( cd ${S}; gnu-configize ) |
| 29 | ( cd ${S}; autoconf ) |
| 30 | oe_runconf |
| 31 | } |