Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Jpeg 2000 implementation" |
| 2 | HOMEPAGE = "https://github.com/mdadams/jasper" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb" |
| 5 | |
| 6 | SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https" |
| 7 | SRCREV = "9aef6d91a82a8a6aecb575cbee57f74470603cc2" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit cmake |
| 12 | |
| 13 | PACKAGECONFIG ??= "" |
| 14 | PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg" |
| 15 | PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut" |
| 16 | |
| 17 | EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true" |
| 18 | |
| 19 | do_install_append() { |
| 20 | chrpath -d ${D}${bindir}/jasper |
| 21 | chrpath -d ${D}${bindir}/imginfo |
| 22 | chrpath -d ${D}${bindir}/imgcmp |
| 23 | chrpath -d ${D}${libdir}/libjasper.so.* |
| 24 | } |