blob: 1d5a29438a11dd928e684bbb7d19499af5c1a92e [file] [log] [blame]
Brad Bishop0a921262019-09-24 07:40:45 -04001SUMMARY = "Jpeg 2000 implementation"
2HOMEPAGE = "https://github.com/mdadams/jasper"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb"
5
6SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https"
7SRCREV = "9aef6d91a82a8a6aecb575cbee57f74470603cc2"
8
9S = "${WORKDIR}/git"
10
11inherit cmake
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg"
15PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut"
16
17EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true"
18
19do_install_append() {
20 chrpath -d ${D}${bindir}/jasper
21 chrpath -d ${D}${bindir}/imginfo
22 chrpath -d ${D}${bindir}/imgcmp
23 chrpath -d ${D}${libdir}/libjasper.so.*
24}