Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame^] | 1 | # Copyright (C) 2014-2015 Freescale Semiconductor |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ |
| 6 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 7 | |
| 8 | SUMMARY = "Set of Bluetooth related tools for inclusion in images" |
| 9 | DESCRIPTION = "Includes bluetooth specific tools for this version of BlueZ.\ |
| 10 | These tools are used at runtime. \ |
| 11 | Supports BlueZ4 and BlueZ5." |
| 12 | |
| 13 | inherit packagegroup |
| 14 | inherit bluetooth |
| 15 | |
| 16 | RDEPENDS_bluez4 = " \ |
| 17 | obexftp \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_bluez5 = " \ |
| 21 | bluez5-noinst-tools \ |
| 22 | bluez5-obex \ |
| 23 | bluez5-testtools \ |
| 24 | libasound-module-bluez \ |
| 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', \ |
| 26 | 'pulseaudio-module-bluetooth-discover \ |
| 27 | pulseaudio-module-bluetooth-policy \ |
| 28 | pulseaudio-module-bluez5-discover \ |
| 29 | pulseaudio-module-bluez5-device \ |
| 30 | pulseaudio-module-switch-on-connect \ |
| 31 | pulseaudio-module-loopback', \ |
| 32 | '', d)} \ |
| 33 | " |
| 34 | |
| 35 | # Install bluez4 tools or bluez5 tools depending on what is specified in the distro. |
| 36 | # Otherwise install nothing. |
| 37 | RDEPENDS_${PN} = "${RDEPENDS_${BLUEZ}}" |