Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A garbage collector for C and C++" |
| 2 | |
| 3 | DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\ |
| 4 | used as a garbage collecting replacement for C malloc or C++ new. It allows\ |
| 5 | you to allocate memory basically as you normally would, without explicitly\ |
| 6 | deallocating memory that is no longer useful. The collector automatically\ |
| 7 | recycles memory when it determines that it can no longer be otherwise\ |
| 8 | accessed.\ |
| 9 | The collector is also used by a number of programming language\ |
| 10 | implementations that either use C as intermediate code, want to facilitate\ |
| 11 | easier interoperation with C libraries, or just prefer the simple collector\ |
| 12 | interface.\ |
| 13 | Alternatively, the garbage collector may be used as a leak detector for C\ |
| 14 | or C++ programs, though that is not its primary goal.\ |
| 15 | Empirically, this collector works with most unmodified C programs, simply\ |
| 16 | by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\ |
| 17 | calls, and removing free calls." |
| 18 | |
| 19 | HOMEPAGE = "http://www.hboehm.info/gc/" |
| 20 | SECTION = "devel" |
| 21 | LICENSE = "MIT" |
| 22 | LIC_FILES_CHKSUM = "file://README.QUICK;md5=55f5088f90a982fed7af9a4897047ef7" |
| 23 | |
| 24 | SRC_URI = "http://www.hboehm.info/gc/gc_source/gc-${PV}.tar.gz \ |
| 25 | file://0001-fix-build-with-musl.patch \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI[md5sum] = "12c05fd2811d989341d8c6d81f66af87" |
| 29 | SRC_URI[sha256sum] = "63320ad7c45460e4a40e03f5aa4c6893783f21a16416c3282b994f933312afa2" |
| 30 | FILES_${PN}-doc = "/usr/share" |
| 31 | |
| 32 | REAL_PV = "${@[d.getVar('PV',1)[:-1], d.getVar('PV',1)][(d.getVar('PV',1)[-1]).isdigit()]}" |
| 33 | S = "${WORKDIR}/gc-${REAL_PV}" |
| 34 | |
| 35 | ARM_INSTRUCTION_SET = "arm" |
| 36 | |
| 37 | inherit autotools pkgconfig |
| 38 | |
| 39 | # by default use external libatomic-ops |
| 40 | PACKAGECONFIG ??= "libatomic-ops" |
| 41 | PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops" |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |