Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Hardware performance monitoring counters" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 2 | HOMEPAGE = "https://team.inria.fr/pacap/software/tiptop/" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | DEPENDS = "ncurses libxml2 bison-native flex-native" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | SRC_URI = "http://files.inria.fr/pacap/${BPN}/${BP}.tar.gz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \ |
| 9 | file://0002-fix-reproducibility-of-build-process.patch \ |
| 10 | file://0001-Fix-build-when-S-B.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | file://0001-Fix-a-lot-of-Werror-format-security-errors-with-mvwp.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182" |
| 14 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | UPSTREAM_CHECK_URI = "https://team.inria.fr/pacap/software/tiptop/" |
| 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | inherit autotools |
| 18 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2"" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_configure:prepend () { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | # Two bugs in configure.ac when cross-compiling. |
| 24 | # 1. The path of libxml2. Specify it in EXTRA_OECONF. |
| 25 | # 2. hw's value on other platforms. Replace it if the target is |
| 26 | # not i*86/x86_64. |
| 27 | if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then |
| 28 | sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac |
| 29 | else |
| 30 | sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac |
| 31 | sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac |
| 32 | fi |
| 33 | } |