Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Midnight Commander is an ncurses based file manager" |
| 2 | HOMEPAGE = "http://www.midnight-commander.org/" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2" |
| 5 | SECTION = "console/utils" |
| 6 | DEPENDS = "ncurses glib-2.0 util-linux" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | RDEPENDS_${PN} = "ncurses-terminfo-base" |
| 8 | RRECOMMENDS_${PN} = "ncurses-terminfo" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \ |
| 11 | file://0001-mc-replace-perl-w-with-use-warnings.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | file://nomandate.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | " |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "9d6358d0a351a455a1410aab57f33b6b48b0fcf31344b9a10b0ff497595979d1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
| 16 | inherit autotools gettext pkgconfig |
| 17 | |
| 18 | # |
| 19 | # Both Samba (smb) and sftp require package delivered from meta-openembedded |
| 20 | # |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba," |
| 23 | PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2," |
| 24 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 25 | CFLAGS_append_libc-musl = ' -DNCURSES_WIDECHAR=1 ' |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 26 | EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
| 28 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 29 | CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'" |
| 30 | CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | do_install_append () { |
| 34 | sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/* |
| 35 | |
| 36 | rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541 |
| 37 | } |
| 38 | |
| 39 | PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish" |
| 40 | |
| 41 | SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts" |
| 42 | FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \ |
| 43 | ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \ |
| 44 | ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \ |
| 45 | ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \ |
| 46 | ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \ |
| 47 | ${libexecdir}/mc/extfs.d/uzip" |
| 48 | RDEPENDS_${BPN}-helpers-perl = "perl" |
| 49 | |
| 50 | SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts" |
| 51 | FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*" |
| 52 | |
| 53 | SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts" |
| 54 | FILES_${BPN}-fish = "${libexecdir}/mc/fish" |