Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A python library for manipulating kickstart files" |
| 2 | HOMEPAGE = "http://fedoraproject.org/wiki/pykickstart" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
| 7 | |
| 8 | DEPENDS = "python3" |
| 9 | RDEPENDS:${PN} = "python3 \ |
| 10 | python3-requests \ |
| 11 | python3-six \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \ |
| 16 | file://0001-support-authentication-for-kickstart.patch \ |
| 17 | file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \ |
| 18 | file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \ |
| 19 | file://0004-load.py-retry-to-invoke-request-with-timeout.patch \ |
| 20 | " |
| 21 | SRCREV = "bfd836cfdd8439d984595aca015811ed5c6be733" |
| 22 | |
| 23 | UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)" |
| 24 | |
| 25 | inherit setuptools3 |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 26 | PIP_INSTALL_PACKAGE = "pykickstart" |
| 27 | PIP_INSTALL_DIST_PATH = "${S}/dist" |