blob: 3c4a5b5a2b691074844529e67bf2ea37d1546468 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
Andrew Geissler5a43b432020-06-13 10:46:56 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
Brad Bishopc342db32019-05-15 21:57:59 -04009
Andrew Geissler5a43b432020-06-13 10:46:56 -050010UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
11UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
12
13SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050014SRC_URI[md5sum] = "c8d4f2aeed6e576bd42f9dc6def1b1ae"
15SRC_URI[sha256sum] = "6648a571a27f186e47094121f0095e1b809e918b3037c630c7f38ffad86e3035"
Brad Bishopc342db32019-05-15 21:57:59 -040016
17inherit autotools pkgconfig lib_package gtk-doc
18
Brad Bishopf3f93bb2019-10-16 14:33:32 -040019PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
20PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo"
21PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig"
22PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype"
23PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
Brad Bishop79641f22019-09-10 07:20:22 -040024PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040025PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
Brad Bishopc342db32019-05-15 21:57:59 -040026
Brad Bishop1d80a2e2019-11-15 16:35:03 -050027PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29LEAD_SONAME = "libharfbuzz.so"
30
Brad Bishopf3f93bb2019-10-16 14:33:32 -040031do_install_append() {
32 # If no tools are installed due to PACKAGECONFIG then this directory is
33 #still installed, so remove it to stop packaging wanings.
34 rmdir --ignore-fail-on-non-empty ${D}${bindir}
35}
36
Brad Bishopc342db32019-05-15 21:57:59 -040037FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
38FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
39 ${libdir}/libharfbuzz-icu.so \
40 ${libdir}/pkgconfig/harfbuzz-icu.pc \
41"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050042FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
Brad Bishopc342db32019-05-15 21:57:59 -040043
44BBCLASSEXTEND = "native nativesdk"