Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame^] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | SECTION = "net" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame^] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "file" |
| 8 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame^] | 10 | SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9" |
| 11 | SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | inherit autotools lib_package pkgconfig gettext |
| 14 | |
| 15 | CFLAGS += "-pthread -D_REENTRANT" |
| 16 | |
| 17 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 18 | |
| 19 | PACKAGECONFIG ?= "curl https" |
| 20 | PACKAGECONFIG_append_class-target = "\ |
| 21 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 22 | " |
| 23 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 24 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 25 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 26 | |
| 27 | do_compile_append() { |
| 28 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 29 | } |