blob: 57fc935f77f179dd0ae3c890207d9f6e758341f9 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
2TDD and BDD - using C++11, C++14, C++17 and later."
3AUTHOR = "Phil Nash, Martin Horenovsky and others"
4HOMEPAGE = "https://github.com/catchorg/Catch2"
5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7
Brad Bishopb809eb92019-09-18 06:27:43 -04008SRC_URI = "git://github.com/catchorg/Catch2.git"
9SRCREV = "2c869e17e4803d30b3d5ca5b0d76387b9db97fa5"
Brad Bishopc342db32019-05-15 21:57:59 -040010
11S = "${WORKDIR}/git"
12
13inherit cmake python3native
14
15do_install_append() {
16 rm ${D}${datadir}/Catch2/lldbinit
17 rm ${D}${datadir}/Catch2/gdbinit
18 rmdir ${D}${datadir}/Catch2/
19}
20# Header-only library
21RDEPENDS_${PN}-dev = ""
22RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"