William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame^] | 1 | SUMMARY = "Header-only C++14 library that gives you an embedded HTTP server" |
| 2 | DESCRIPTION = "Cross-platform, efficient, customizable, and robust \ |
| 3 | asynchronous HTTP/WebSocket server C++14 library with the \ |
| 4 | right balance between performance and ease of use" |
| 5 | AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>" |
| 6 | HOMEPAGE = "https://stiffstream.com/en/products/restinio.html" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=f399b62ce0a152525d1589a5a40c0ff6" |
| 10 | DEPENDS = "asio fmt http-parser" |
| 11 | |
| 12 | SRC_URI = "https://github.com/Stiffstream/restinio/releases/download/v.${PV}/restinio-${PV}.tar.bz2" |
| 13 | SRC_URI[md5sum] = "37a4310e98912030a74bdd4ed789f33c" |
| 14 | SRC_URI[sha256sum] = "b35d696e6fafd4563ca708fcecf9d0cf6705c846d417b5000f5252e0188848e7" |
| 15 | |
| 16 | S = "${WORKDIR}/${PN}-${PV}/dev" |
| 17 | |
| 18 | inherit cmake |
| 19 | |
| 20 | EXTRA_OECMAKE += "\ |
| 21 | -DRESTINIO_TEST=OFF \ |
| 22 | -DRESTINIO_SAMPLE=OFF \ |
| 23 | -DRESTINIO_BENCH=OFF \ |
| 24 | -DRESTINIO_FIND_DEPS=ON \ |
| 25 | -DRESTINIO_ALLOW_SOBJECTIZER=OFF \ |
| 26 | -DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON \ |
| 27 | " |
| 28 | |
| 29 | # Header-only library |
| 30 | RDEPENDS_${PN}-dev = "" |
| 31 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |