blob: 3d75f0604b5c7a8122c4f6eb128849b7bf010de4 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Gnuplot is a portable command-line driven graphing utility"
2DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
3(text or binary) and function plotting utility."
4HOMEPAGE = "http://www.gnuplot.info/"
5SECTION = "console/scientific"
6LICENSE = "gnuplot"
7LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
8DEPENDS = "${BPN}-native virtual/libx11 gd readline"
9
Brad Bishop8410d612019-11-25 09:40:59 -050010inherit autotools features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040011# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
13
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070014SRC_URI = " \
15 ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz;name=archive \
Brad Bishop316dfdd2018-06-25 12:45:53 -040016 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
17 file://gnuplot.desktop \
18 file://gnuplot.png \
19"
20SRC_URI_append_class-target = " \
21 file://0002-do-not-build-demos.patch \
22 file://0003-Use-native-tools-to-build-docs.patch \
23 file://0004-Add-configure-option-to-find-qt5-native-tools.patch \
24"
25
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070026SRC_URI[archive.sha256sum] = "6b690485567eaeb938c26936e5e0681cf70c856d273cc2c45fabf64d8bc6590e"
Brad Bishop316dfdd2018-06-25 12:45:53 -040027SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"
28
29# for building docs (they deserve it) we need *doc2* tools native
30BBCLASSEXTEND = "native"
31DEPENDS_class-native = "readline-native"
32PACKAGECONFIG_class-native = ""
33
Andrew Geissler4b7c1152020-11-30 19:55:29 -060034SRC_URI_append_class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
36do_install_class-native() {
37 install -d ${D}${bindir}
38 install ${B}/docs/*doc* ${D}${bindir}
39 rm ${D}${bindir}/*.o
40}
41
42PACKAGECONFIG ??= "cairo"
43PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
44PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
45PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native"
46
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070047EXTRA_OECONF = " \
48 --with-readline=${STAGING_LIBDIR}/.. \
49 -disable-wxwidgets \
50"
Brad Bishop316dfdd2018-06-25 12:45:53 -040051
52do_compile_prepend() {
53 install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
54}
55
56do_install_append_class-target() {
57 install -d ${D}${datadir}/applications/
58 install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
59 install -d ${D}${datadir}/pixmaps/
60 install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
61}
62
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080063PACKAGES =+ "${PN}-x11"
64
65RPROVIDES_${PN}-dbg += "${PN}-x11-dbg"
66
Brad Bishop316dfdd2018-06-25 12:45:53 -040067DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
68SECTION_${PN}-x11 = "x11/scientific"
69FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
70
71FILES_${PN} += "${datadir}/texmf"