William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame^] | 1 | # |
| 2 | # Copyright (C) 2014 Wind River Systems, Inc. |
| 3 | # Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms) |
| 4 | # |
| 5 | SUMMARY = "A compression/decompression library" |
| 6 | DESCRIPTION = "Snappy is a fast data compression and decompression library \ |
| 7 | It was designed to be very fast and stable, but not to achieve a high \ |
| 8 | compression ratio." |
| 9 | |
| 10 | LICENSE = "BSD-3-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c" |
| 12 | |
| 13 | SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https \ |
| 14 | file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \ |
| 15 | " |
| 16 | SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | |
| 20 | inherit cmake pkgconfig |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo," |
| 24 | TARGET_CFLAGS += "-fPIC" |
| 25 | |
| 26 | EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" -DSNAPPY_BUILD_TESTS="OFF" -DSNAPPY_BUILD_BENCHMARKS="OFF"' |