Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | inherit features_check binconfig lib_package gtk-icon-cache mime mime-xdg |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | REQUIRED_DISTRO_FEATURES = "x11" |
| 7 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | EXTRA_OECMAKE = " \ |
| 9 | -DOPTION_BUILD_SHARED_LIBS=ON \ |
| 10 | -DOPTION_USE_THREADS=ON \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame^] | 11 | -DFLTK_BUILD_TEST=OFF \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | -DOPTION_USE_XDBE=ON \ |
| 13 | -DOPTION_USE_XFT=ON \ |
| 14 | -DFLTK_CONFIG_PATH=${libdir}/cmake \ |
| 15 | " |
| 16 | |
| 17 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" |
| 18 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl" |
| 21 | PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama" |
| 22 | PACKAGECONFIG[xfixes] = "-DOPTION_USE_XFIXES=ON,-DOPTION_USE_XFIXES=OFF,libxfixes" |
| 23 | PACKAGECONFIG[xcursor] = "-DOPTION_USE_XCURSOR=ON,-DOPTION_USE_XCURSOR=OFF,libxcursor" |
| 24 | |
| 25 | do_install_append() { |
| 26 | sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config |
| 27 | } |
| 28 | |
| 29 | python populate_packages_prepend () { |
| 30 | if (d.getVar('DEBIAN_NAMES')): |
| 31 | d.setVar('PKG_${BPN}', 'libfltk${PV}') |
| 32 | } |
| 33 | |
| 34 | LEAD_SONAME = "libfltk.so" |
| 35 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | # .desktop / icons / mime only necessary for fluid app |
| 37 | FILES_${PN}-bin += " \ |
| 38 | ${datadir}/applications \ |
| 39 | ${datadir}/icons \ |
| 40 | ${datadir}/mime \ |
| 41 | " |
| 42 | |
| 43 | # cmake files |
| 44 | FILES_${PN}-dev += "${datadir}/fltk" |