blob: d95ab109a323de722833300556b88878ffeb5ef9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
Andrew Geisslerd221e032020-07-10 16:13:21 -050014PYPI_PACKAGE_EXT = "zip"
Andrew Geissler32b11992021-03-31 13:37:05 -050015
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070016SRC_URI[sha256sum] = "93c2107f789fd897f234f4b8f1ba8e7b9f4ef326d9bcbfceb71dda8cc197388c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
27"