Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "A lightweight hotkey daemon" |
| 2 | HOMEPAGE = "https://github.com/wertarbyte/triggerhappy" |
| 3 | |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
Brad Bishop | ba6de43 | 2019-05-21 08:07:33 -0400 | [diff] [blame^] | 7 | # matches debian/0.5.0-1 tag |
| 8 | SRCREV = "44a173195986d0d853316cb02a58785ded66c12b" |
| 9 | PV = "0.5.0+git${SRCPV}" |
| 10 | SRC_URI = "git://github.com/wertarbyte/${BPN}.git;branch=debian" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
Brad Bishop | ba6de43 | 2019-05-21 08:07:33 -0400 | [diff] [blame^] | 12 | S = "${WORKDIR}/git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | inherit autotools-brokensep pkgconfig update-rc.d systemd |
| 15 | |
| 16 | PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" |
| 17 | PACKAGECONFIG[systemd] = ",,systemd" |
| 18 | |
| 19 | INITSCRIPT_NAME = "triggerhappy" |
| 20 | INITSCRIPT_PARAMS = "defaults" |
| 21 | SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket" |
| 22 | |
| 23 | FILES_${PN} = "\ |
Brad Bishop | ba6de43 | 2019-05-21 08:07:33 -0400 | [diff] [blame^] | 24 | ${sbindir}/thd \ |
| 25 | ${sbindir}/th-cmd \ |
| 26 | ${sysconfdir}/triggerhappy/triggers.d \ |
| 27 | ${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \ |
| 28 | ${sysconfdir}/init.d/triggerhappy \ |
| 29 | ${systemd_unitdir}/system \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | " |
| 31 | CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules" |
| 32 | |
| 33 | do_install_append() { |
| 34 | install -d ${D}${sysconfdir}/triggerhappy/triggers.d |
| 35 | |
| 36 | install -d ${D}${nonarch_base_libdir}/udev/rules.d |
| 37 | install -m 0644 ${S}/udev/triggerhappy-udev.rules ${D}${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules |
| 38 | |
| 39 | install -d ${D}${sysconfdir}/init.d |
| 40 | install -m 0755 ${S}/debian/init.d ${D}${sysconfdir}/init.d/triggerhappy |
| 41 | |
| 42 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 43 | install -d ${D}/${systemd_unitdir}/system |
| 44 | install -m 0644 ${S}/systemd/triggerhappy.socket ${D}${systemd_unitdir}/system |
| 45 | install -m 0644 ${S}/systemd/triggerhappy.service ${D}${systemd_unitdir}/system |
| 46 | fi |
| 47 | } |