Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM's Software TPM 2.0" |
| 2 | DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \ |
| 3 | education, and virtualization. \ |
| 4 | \ |
| 5 | The intent is that an application can be developed using the software TPM. \ |
| 6 | The application should then run using a hardware TPM without changes. \ |
| 7 | Advantages of this approach: \ |
| 8 | * In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \ |
| 9 | * Application software errors are easily reversed by simply removing the TPM state and starting over. \ |
| 10 | * Difficult crypto errors are quickly debugged by looking inside the TPM." |
| 11 | HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 13 | SECTION = "securty/tpm" |
| 14 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f" |
| 15 | |
| 16 | DEPENDS = "openssl" |
| 17 | |
| 18 | SRC_URI = "https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm${PV}.tar.gz \ |
| 19 | file://tune-makefile.patch \ |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 20 | " |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "3cb642f871a17b23d50b046e5f95f449c2287415fc1e7aeb4bdbb8920dbcb38f" |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame] | 22 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 23 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/ibmswtpm2/files/" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 24 | |
| 25 | S = "${WORKDIR}/src" |
| 26 | |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 27 | CFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 28 | |
| 29 | do_compile () { |
| 30 | make CC='${CC}' |
| 31 | } |
| 32 | |
| 33 | do_install () { |
| 34 | install -d ${D}/${bindir} |
| 35 | install -m 0755 tpm_server ${D}/${bindir} |
| 36 | } |