Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | SUMMARY = "A set of tools using pywbem" |
| 2 | DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers" |
| 3 | HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa" |
| 6 | |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame^] | 7 | SRC_URI[md5sum] = "e41ef654a0af0461d6c164752963fdfb" |
| 8 | SRC_URI[sha256sum] = "b869bb217613cdfee1e97e8afc28fe3f9bf3b88f8fc99e588d03c4be0922c319" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | DEPENDS += " \ |
| 13 | ${PYTHON_PN}-pyyaml-native \ |
| 14 | ${PYTHON_PN}-pywbem-native \ |
| 15 | ${PYTHON_PN}-six-native \ |
| 16 | ${PYTHON_PN}-click-native \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS_${PN}_class-target += "\ |
| 20 | ${PYTHON_PN}-ply \ |
| 21 | ${PYTHON_PN}-pyyaml \ |
| 22 | ${PYTHON_PN}-six \ |
| 23 | ${PYTHON_PN}-pywbem \ |
| 24 | ${PYTHON_PN}-click \ |
| 25 | ${PYTHON_PN}-requests \ |
| 26 | ${PYTHON_PN}-prompt-toolkit \ |
| 27 | ${PYTHON_PN}-mock \ |
| 28 | ${PYTHON_PN}-packaging \ |
| 29 | ${PYTHON_PN}-nocasedict \ |
| 30 | ${PYTHON_PN}-yamlloader \ |
| 31 | ${PYTHON_PN}-click-repl \ |
| 32 | ${PYTHON_PN}-click-spinner \ |
| 33 | ${PYTHON_PN}-asciitree \ |
| 34 | ${PYTHON_PN}-tabulate \ |
| 35 | ${PYTHON_PN}-pydicti \ |
| 36 | ${PYTHON_PN}-nocaselist \ |
| 37 | ${PYTHON_PN}-custom-inherit \ |
| 38 | " |
| 39 | |
| 40 | BBCLASSEXTEND = "native" |