blob: fcdb2aee4d8f185019bed724fd493fb7586a7361 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNOME library for reading .desktop files"
2SECTION = "x11/gnome"
3LICENSE = "GPLv2 & LGPLv2"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05004LIC_FILES_CHKSUM = " \
5 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
7"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9BPN = "gnome-desktop"
10
11GNOMEBASEBUILDCLASS = "meson"
12
13inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check
14
15# gobject-introspection is mandatory and cannot be configured
16REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
17UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
18
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019SRC_URI[archive.sha256sum] = "eea1242994109fa3f05793963ee25c3df23bc84b0f0b81f03ec3c294c27ab753"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21SRC_URI += " \
22 file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \
23 file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \
24"
25
26DEPENDS += "gsettings-desktop-schemas virtual/libx11 gtk+3 startup-notification xkeyboard-config iso-codes udev"
27
28inherit features_check gtk-doc
29REQUIRED_DISTRO_FEATURES += "x11"
30
31GTKDOC_MESON_OPTION = "gtk_doc"
32EXTRA_OEMESON = "-Ddesktop_docs=false"
33
34PACKAGES =+ "libgnome-desktop3"
35FILES_libgnome-desktop3 = "${libdir}/lib*${SOLIBS} ${datadir}/libgnome-desktop*/pnp.ids ${datadir}/gnome/*xml"
36
37RRECOMMENDS_libgnome-desktop3 += "gsettings-desktop-schemas"